Ihr Browser versucht gerade eine Seite aus dem sogenannten Internet auszudrucken. Das Internet ist ein weltweites Netzwerk von Computern, das den Menschen ganz neue Möglichkeiten der Kommunikation bietet.

Da Politiker im Regelfall von neuen Dingen nichts verstehen, halten wir es für notwendig, sie davor zu schützen. Dies ist im beidseitigen Interesse, da unnötige Angstzustände bei Ihnen verhindert werden, ebenso wie es uns vor profilierungs- und machtsüchtigen Politikern schützt.

Sollten Sie der Meinung sein, dass Sie diese Internetseite dennoch sehen sollten, so können Sie jederzeit durch normalen Gebrauch eines Internetbrowsers darauf zugreifen. Dazu sind aber minimale Computerkenntnisse erforderlich. Sollten Sie diese nicht haben, vergessen Sie einfach dieses Internet und lassen uns in Ruhe.

Die Umgehung dieser Ausdrucksperre ist nach §95a UrhG verboten.

Mehr Informationen unter www.politiker-stopp.de.


[lang_de]Mail.app Fehler unter Leopard[/lang_de][lang_en]buggy Mail.app in Leopard[/lang_en]

1 04 2008

[lang_de]
Mail.app Icon

Jetzt habe ich endlich den Beweis, daß sich Mail.app unter Leopard zumindest komisch verhält. Ich hatte das ja schon in einem Podcast angekündigt und nach Beweisen gesucht.
Hintergrund war der gestiegene Traffic auf meinem Root-Server. Der ist in einem Maße gestiegen, der mit normalen Web-Verhalten nicht zu erklären war. Auch die Google Analytics Statistiken deuteten nicht auf erhöhten Web-Traffic hin. Also mußte die Ursache dafür woanders liegen.

Ich hatte recht bald Mail.app in Verdacht, daß der Erhöhte Traffic mit dem Update auf MacOS 10.5 Leopard einher zu gehen schien.
Also habe ich ntop auf meinem Root-Server installiert um der Sache auf die Spur zu kommen.

Just heute hat sich Mail.app mal wieder verabschiedet. Es ließ sich nicht mehr normal beenden. Hing ewig fest. Dann habe ich es über “sofort beenden” gekillt und neu gestartet. Sah eigentlich alles normal aus. Die Mailboxen waren alle noch da, die Mails auch und Mail verhielt sich wie immer.
Allerdings erhielt ich einige Zeit danach eine Traffic-Warnung von meinem Provider, daß das Traffic-Limit für den Traffic/Stunde überschritten wurde.

Also fluchs im ntop nachgeschaut und dort gesehen, daß in kürzester Zeit ca. 1 GB an Traffic auf dem IMAP-Port zwischen meinem Server und unserem Office hier übertragen wurde. Somit ist also klar, daß der Traffic durch Mail.app verursacht wird.

Leider läßt sich nicht so einfach klären warum. Im Logfile unter MacOS X stehen zwar einige Meldung bzgl. Mail.app, jedoch nichts gibt einen Hinweis darauf, warum jetzt nach dem Kaltstart von Mail.app plötzlich solche riesigen Datenmengen übertragen werden müssen.

Es scheint ja ein kompletter Scan der Mailbox vorgenommen worden zu sein. Das scheint mir aber etwas übertrieben für einen simplen Neustart von Mail.app
[/lang_de]
[lang_en]
Mail.app Icon

I finally got the evidence that Apples Mail.app from Leopard is causing the exceeding traffic I see on my root server. I mentioned this before in the podcast that there is something strange since the upgrade to MacOS X 10.5.
Since the update I got more traffic warnings from my provider. I didn’t believe this was due to increasing popularity of this blog and Google Analytics proofed that (unfortunatly). I then installed ntop traffic monitoring on my server to further track down the source of the exceeding traffic.
I had Apple Mail under suspicion because the problems started when some people around me and myself upgraded to Leopard.

Now I got the proof that this is caused by Mail.app. The new Mail.app in Leopard isn’t that stable and so it hangs from time to time. Then I can’t even quit it with forcing it to quit. So was this morning. Some of the Mail.app plugins stopped working and I decided to quit and restart Mail.app. But Mail.app hang during shutdown and wasn’t responding for more than 10 minutes. So I force quitted it and restartet Mail.app.

Everythings seems fine after restart. All my mailboxes where there, messages too and all the plugins where working properly.
But a few minutes after the restart I got another traffic warning from my provider stating that something had transfered 1 GB of data. I checked ntop and saw that this was IMAP traffic from my server to our office. So it was clear that this was caused by my cold started Mail.app

I also checked the system log of Leopard but didn’t found any usefull information on this behaviour of Mail.app. It seems that Mail.app had rescanned or even retransfered my whole IMAP mailbox due to this hard restart. But I can explain why that must happen.

[/lang_en]

Technorati Tags: , ,


Actions

Informations